Koala - Search functionality unavailable – Incident details

Search functionality unavailable

Resolved
Partial outage
Started about 2 years agoLasted about 3 hours

Affected

app

Partial outage from 5:20 PM to 8:20 PM

Updates
  • Resolved
    Resolved

    This issue has been resolved and we continue to monitor.

  • Monitoring
    Monitoring

    We implemented a fix and currently monitoring the result. Search functionality should be back fully, as we continue to reindex the latest data to our OpenSearch cluster.

  • Identified
    Identified

    We've identified the issue – our OpenSearch cluster was inadvertently replaced through an unrelated Terraform change due to version mismatches. No data is lost. We are currently restoring the cluster from a recent snapshot and will begin reindexing all documents to restore functionality.

  • Investigating
    Investigating

    All search functionality has become unavailable. We are currently investigating this incident.